<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	
	<link rel="profile" href="https://gmpg.org/xfn/11">
		<title>Low Temperatures Lead Into Spring Weather Ahead &#8211; NBC Boston</title>
<link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/Roboto-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/Roboto-Regular.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/Roboto-Italic.woff2" as="font" crossorigin /><link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC Boston &raquo; Feed" href="https://www.nbcboston.com/?rss=y" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.nbcboston.com/_static/??-eJyd0UtuxCAMBuALlRDyIGRR9SyOMRM0PCIgqnL7MqmmatVZtLO18WeLn79vDGMoFArf3H6xIXPQzMFBKbOwIMf8vaLN1tTKC//f3NeMDeh2Tflsa5sLX1zEK3N2SZAOnsvhqPE2/Nrid3ZflAkSrpwc5GJxS3S3bmiq5UKabTGXzD71U80P2bKSr+fUi+srKDYGjs7eOstunT7JEAP4rZnU2AulpeqFMbMhNdP0tInR+xgaPUgJaLpZ6g7bzkipZIPrHq5PyxcXF3BNJ4SEiRBl2yOBkN2MT5uQ6kfXYCbVqrYfOmp7Q6QAB/UY/WtaBpBqTD8DevOvQopBqXEc5QeFl/Lv' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZdVrKMPVJCcn1eSmleiX5BTmp6ZV6yfmKKbk1iZWlSsm5eUDNKFEEhJKyBdF1CHfa6toZmBiYGBsbGJQRYAeeU15w=='></script>
<script src='https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script id='nbc-analytics-js-js-extra'>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</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??/wp-includes/js/dist/i18n.min.js,/wp-content/themes/nbc-station/client/build/js/analytics.27f5f9402a42a5ea1a7d.bundle.min.js?m=1614885556j'></script>
<link rel="https://api.w.org/" href="https://www.nbcboston.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcboston.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcboston.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel="canonical" href="https://www.nbcboston.com/weather/stories-weather/low-temperatures-preface-spring-temperatures-ahead/2321529/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcboston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcboston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	@media (max-width: 375px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcboston.com/2019/09/NBC_Boston-2.png?resize=1440%2C415&#038;quality=85&#038;strip=all'); }
	}
	@media (min-width: 376px) and (max-width: 768px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcboston.com/2019/09/NBC_Boston-2.png?resize=1440%2C415&#038;quality=85&#038;strip=all'); }
	}
	@media (min-width: 769px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcboston.com/2019/09/NBC_Boston-2.png?resize=1440%2C415&#038;quality=85&#038;strip=all'); }
	}
</style>
		<!-- Begin comScore Tag -->
		<script>
		var _comscore = _comscore || [];
		_comscore.push({ c1: "2", c2: "6035083" });
		(function() {
			var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
			s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
			el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
		<meta property="og:site_name" content="NBC Boston" /><meta name="google-site-verification" content="SCT2EhBzLX0R1J6GJ9IYDwEfS2yDR4CS4hEITRHfekw" /><meta property="fb:app_id" content="168250447207" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbc10boston" /><meta name="twitter:creator" content="@nbc10boston" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="https://www.facebook.com/NBC10Boston/" /><meta name="description" content="Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there..." /><meta property="og:description" content="Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there is sunshine to keep us warm and content." /><meta name="twitter:description" content="Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there is sunshine to keep us warm and content." /><meta property="og:title" content="Low Temperatures Lead Into Spring Weather Ahead" /><meta name="twitter:title" content="Low Temperatures Lead Into Spring Weather Ahead" /><meta name="keywords" content="temperatures, weather new england" /><meta property="og:url" content="https://www.nbcboston.com/weather/stories-weather/low-temperatures-preface-spring-temperatures-ahead/2321529/" /><meta name="twitter:url" content="https://www.nbcboston.com/weather/stories-weather/low-temperatures-preface-spring-temperatures-ahead/2321529/" /><meta name="sailthru.title" content="Low Temperatures Lead Into Spring Weather Ahead" /><meta name="sailthru.description" content="Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there..." /><meta name="sailthru.tags" content="temperatures, weather new england" /><meta name="sailthru.tags" content="temperatures, weather new england" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2021-03-06T13:15:23+00:00" /><meta property="og:image:width" content="640" /><meta property="og:image:height" content="354" /><meta property="og:image" content="https://i2.wp.com/media.nbcboston.com/2021/03/WeatherSaturday.png?fit=640%2C354&amp;quality=85&amp;resize=1200%2C675&amp;strip=all&amp;ssl=1" /><meta name="twitter:image" content="https://i2.wp.com/media.nbcboston.com/2021/03/WeatherSaturday.png?fit=640%2C354&amp;quality=85&amp;resize=1200%2C675&amp;strip=all&amp;ssl=1" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcboston.com\/weather\/stories-weather\/low-temperatures-preface-spring-temperatures-ahead\/2321529\/","headline":"Low Temperatures Lead Into Spring Weather Ahead","datePublished":"2021-03-06T13:15:23","dateModified":"2021-03-06T13:23:10","description":"Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"temperatures, weather new england","publisher":{"@type":"Organization","name":"NBC10 Boston","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcboston.com\/wp-content\/uploads\/2019\/09\/light_amp_wbts.png","width":160}},"image":{"@type":"ImageObject","height":354,"url":"https:\/\/media.nbcboston.com\/2021\/03\/WeatherSaturday.png?fit=640%2C354&quality=85&strip=all","width":640},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.nbcboston.com\/weather\/stories-weather\/low-temperatures-preface-spring-temperatures-ahead\/2321529\/","description":"Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there is sunshine to keep us warm and content.","duration":"PT02M23S","name":"Low Temperatures Lead Into Spring Weather Ahead","thumbnailUrl":"https:\/\/media.nbcboston.com\/2021\/03\/WeatherSaturday.png?fit=640%2C354&quality=85&strip=all","uploadDate":"2021-03-06T13:15:23"},"author":{"@type":"Person","name":"Denise Isaac"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcboston.com/weather/stories-weather/low-temperatures-preface-spring-temperatures-ahead/2321529/?amp"><link rel="icon" href="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=32%2C32&#038;quality=85&#038;strip=all" sizes="32x32" />
<link rel="icon" href="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=192%2C192&#038;quality=85&#038;strip=all" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=180%2C180&#038;quality=85&#038;strip=all" />
<meta name="msapplication-TileImage" content="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=270%2C270&#038;quality=85&#038;strip=all" />

                    <script>var w=window;if(w.performance||w.mozPerformance||w.msPerformance||w.webkitPerformance){var d=document;AKSB=w.AKSB||{},AKSB.q=AKSB.q||[],AKSB.mark=AKSB.mark||function(e,_){AKSB.q.push(["mark",e,_||(new Date).getTime()])},AKSB.measure=AKSB.measure||function(e,_,t){AKSB.q.push(["measure",e,_,t||(new Date).getTime()])},AKSB.done=AKSB.done||function(e){AKSB.q.push(["done",e])},AKSB.mark("firstbyte",(new Date).getTime()),AKSB.prof={custid:"527847",ustr:"",originlat:"0",clientrtt:"1",ghostip:"23.201.31.180",ipv6:false,pct:"10",clientip:"107.23.218.4",requestid:"38894825",region:"30888",protocol:"",blver:14,akM:"x",akN:"ae",akTT:"O",akTX:"1",akTI:"38894825",ai:"343797",ra:"false",pmgn:"",pmgi:"",pmp:"",qc:""},function(e){var _=d.createElement("script");_.async="async",_.src=e;var t=d.getElementsByTagName("script"),t=t[t.length-1];t.parentNode.insertBefore(_,t)}(("https:"===d.location.protocol?"https:":"http:")+"//ds-aksb-a.akamaihd.net/aksb.min.js")}</script>
                    </head>

<body class="post-template-default single single-post postid-2321529 single-format-standard station-nbc wbts has-featured-image short-hero">
	<div id="fb-root"></div>
		<script
			async
			defer
			crossorigin="anonymous"
			src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=168250447207&autoLogAppEvents=1"></script>
		<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcboston.com/">
						<img
							src="https://media.nbcboston.com/2019/09/Boston_On_Dark@3x-2.png?fit=435%2C120&#038;quality=85&#038;strip=all"
							alt="NBC Boston"
							loading="lazy"
						/>
					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcboston.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Videos" data-lpos="primary-menu" class=" menu-item menu-item-type-post_type menu-item-object-page" href="https://www.nbcboston.com/videos/">Videos</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/sports/">Sports</a></li>
<a data-lid="Traffic" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/traffic/">Traffic</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcboston.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="READ: New Mass. Reopening Plan" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/coronavirus/read-baker-administration-plans-massachusetts-phase-3-step-2-phase-4/2313147/" class="site-header__trending-nav-item">READ: New Mass. Reopening Plan</a>
					<a data-lid="10 Questions" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/local/10-questions-with-nbc10-boston/" class="site-header__trending-nav-item">10 Questions</a>
					<a data-lid="Plan Your Vaccine" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/coronavirus/plan-your-vaccine-find-out-how-to-get-a-vaccine-anywhere-in-the-us/2300107/" class="site-header__trending-nav-item">Plan Your Vaccine</a>
					<a data-lid="How Do I Get a COVID Vaccine?" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/coronavirus/how-do-i-get-the-covid-vaccine-a-how-to-guide-for-massachusetts/2309263/" class="site-header__trending-nav-item">How Do I Get a COVID Vaccine?</a>
					<a data-lid="MA COVID Tracker" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/coronavirus/mass-covid-19-tracker-maps-charts-data/2169900/" class="site-header__trending-nav-item">MA COVID Tracker</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather "
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="2201">
	</div>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
	</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2321529" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcboston.com/tag/weather-new-england/">weather new england</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Low Temperatures Lead Into Spring Weather Ahead	</h1>
			<h2 class="article-subtitle">
			Ski areas will pick up between 1-3 inches of fresh snow		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By <a href="https://www.nbcboston.com?s=Author%3A%20%22Denise%20Isaac%22">Denise Isaac</a>							<span class="meta-dot">&bull;</span>
					
							<span class="time-wrap">
				<time class="entry-date published" datetime="2021-03-06T18:15:23-05:00">Published 27 mins ago</time>					<span class="meta-dot">&bull;</span>
				<time class="entry-date updated" datetime="2021-03-06T13:23:10-05:00">Updated 19 mins ago</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F&#038;Low%20Temperatures%20Lead%20Into%20Spring%20Weather%20Ahead?_osource=db_npd_nbc_wbts_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Low%20Temperatures%20Lead%20Into%20Spring%20Weather%20Ahead&#038;url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F?_osource=db_npd_nbc_wbts_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Low%20Temperatures%20Lead%20Into%20Spring%20Weather%20Ahead%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F?_osource=db_npd_nbc_wbts_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
	</div>
</div>
	</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:11:2420458&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_primary_category_id&quot;:199930,&quot;nbc_primary_tag_id&quot;:31882,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;11&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:11:199930&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_NECN\/334\/759\/7764396062.dfxp&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS_-_NECN\/334\/759\/7764396062-1080pnbcnews6m.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;FRILRVASPMzP&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;jyJnzsKv3lrq&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcboston.com\/2021\/03\/WeatherSaturday-1.png?crop&amp;resize=850%2C478&amp;quality=85&amp;strip=all&quot;,&quot;pid_streaming_web_high&quot;:&quot;egrx8KyFh3c6&quot;,&quot;pid_streaming_web_medium&quot;:&quot;jyJnzsKv3lrq&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NECN&quot;,&quot;video_captions&quot;:&quot;WINTER IS HOLDING ON TIGHT THIS WINTER IS HOLDING ON TIGHT THIS WEEKEND WITH BELOW AVERAGE WINTER IS HOLDING ON TIGHT THIS WEEKEND WITH BELOW AVERAGE TEMPERATURES TOSS TO DENISE WEEKEND WITH BELOW AVERAGE TEMPERATURES TOSS TO DENISE WINTER IS HOLDING ON TIGHT THIS TEMPERATURES TOSS TO DENISE WINTER IS HOLDING ON TIGHT THIS WEEKEND WITH BELOW AVERAGE WINTER IS HOLDING ON TIGHT THIS WEEKEND WITH BELOW AVERAGE TEMPERATURES AND A LIGHT BREEZE WEEKEND WITH BELOW AVERAGE TEMPERATURES AND A LIGHT BREEZE CREATING WIND CHILLS IN THE TEMPERATURES AND A LIGHT BREEZE CREATING WIND CHILLS IN THE SINGLE DIGITS AND TEENS. AT CREATING WIND CHILLS IN THE SINGLE DIGITS AND TEENS. AT LEAST THERE IS SUNSHINE TO KEEP SINGLE DIGITS AND TEENS. AT LEAST THERE IS SUNSHINE TO KEEP US \&quot;WARM\&quot; AND CONTENT. THE AIR LEAST THERE IS SUNSHINE TO KEEP US \&quot;WARM\&quot; AND CONTENT. THE AIR MASS IS VERY DRY SO IT )S US \&quot;WARM\&quot; AND CONTENT. THE AIR MASS IS VERY DRY SO IT )S IMPERATIVE THAT YOU USE LOTION MASS IS VERY DRY SO IT )S IMPERATIVE THAT YOU USE LOTION AND CHAPSTICK TO KEEP YOUR SKIN IMPERATIVE THAT YOU USE LOTION AND CHAPSTICK TO KEEP YOUR SKIN HYDRATED. A WAVE OF ENERGY WILL AND CHAPSTICK TO KEEP YOUR SKIN HYDRATED. A WAVE OF ENERGY WILL DROP FROM CANADA AND IT WILL HYDRATED. A WAVE OF ENERGY WILL DROP FROM CANADA AND IT WILL ENHANCE UPSLOPE SNOW SHOWERS FOR DROP FROM CANADA AND IT WILL ENHANCE UPSLOPE SNOW SHOWERS FOR THE MOUNTAINS OF VERMONT, NEW ENHANCE UPSLOPE SNOW SHOWERS FOR THE MOUNTAINS OF VERMONT, NEW HAMPSHIRE AND BERKSHIRES AS WELL THE MOUNTAINS OF VERMONT, NEW HAMPSHIRE AND BERKSHIRES AS WELL AS LITCHFIELD HILLS WITH SKI HAMPSHIRE AND BERKSHIRES AS WELL AS LITCHFIELD HILLS WITH SKI AREAS PICKING UP BETWEEN 1-3 AS LITCHFIELD HILLS WITH SKI AREAS PICKING UP BETWEEN 1-3 INCHES OF FRESH SNOW. A MAINLY AREAS PICKING UP BETWEEN 1-3 INCHES OF FRESH SNOW. A MAINLY CLEAR SKY IS EXPECTED TONIGHT INCHES OF FRESH SNOW. A MAINLY CLEAR SKY IS EXPECTED TONIGHT WITH LOWS IN THE SINGLE DIGITS CLEAR SKY IS EXPECTED TONIGHT WITH LOWS IN THE SINGLE DIGITS AND TEENS NORTH, WHILE TEENS AND WITH LOWS IN THE SINGLE DIGITS AND TEENS NORTH, WHILE TEENS AND 20S SOUTH. AND TEENS NORTH, WHILE TEENS AND 20S SOUTH. HIGH PRESSURE WILL TAKE CONTROL 20S SOUTH. HIGH PRESSURE WILL TAKE CONTROL OF THE REGION SUNDAY UNDER A HIGH PRESSURE WILL TAKE CONTROL OF THE REGION SUNDAY UNDER A MOSTLY SUNNY SKY AND LESS WIND, OF THE REGION SUNDAY UNDER A MOSTLY SUNNY SKY AND LESS WIND, BUT IT STAYS CHILLY WITH HIGHS MOSTLY SUNNY SKY AND LESS WIND, BUT IT STAYS CHILLY WITH HIGHS IN THE 30S. BUT IT STAYS CHILLY WITH HIGHS IN THE 30S. A WARM FRONT WILL ALLOW CLOUDS IN THE 30S. A WARM FRONT WILL ALLOW CLOUDS AND TEMPERATURES TO INCREASE A WARM FRONT WILL ALLOW CLOUDS AND TEMPERATURES TO INCREASE MONDAY WITH A SLIGHT CHANCE FOR AND TEMPERATURES TO INCREASE MONDAY WITH A SLIGHT CHANCE FOR SHOWER AND EVEN SNOW NEAR THE MONDAY WITH A SLIGHT CHANCE FOR SHOWER AND EVEN SNOW NEAR THE INTERNATIONAL BORDER. GOOD NEWS SHOWER AND EVEN SNOW NEAR THE INTERNATIONAL BORDER. GOOD NEWS IS, THIS FRONT WILL OPEN THE INTERNATIONAL BORDER. GOOD NEWS IS, THIS FRONT WILL OPEN THE DOOR TO WARMER AIR TUESDAY WITH IS, THIS FRONT WILL OPEN THE DOOR TO WARMER AIR TUESDAY WITH HIGHS IN THE 40S NORTH, 50S DOOR TO WARMER AIR TUESDAY WITH HIGHS IN THE 40S NORTH, 50S SOUTH. HIGHS IN THE 40S NORTH, 50S SOUTH. THEN, A BIG WARM UP IS IN STORE SOUTH. THEN, A BIG WARM UP IS IN STORE MIDWEEK, THIS WILL BE OUR FIRST THEN, A BIG WARM UP IS IN STORE MIDWEEK, THIS WILL BE OUR FIRST PROLONGED STRETCH OF SPRING-LIKE MIDWEEK, THIS WILL BE OUR FIRST PROLONGED STRETCH OF SPRING-LIKE WEATHER, WITH HIGHS IN THE 60S PROLONGED STRETCH OF SPRING-LIKE WEATHER, WITH HIGHS IN THE 60S AND A FEW SPOTS NEAR 70 THURSDAY WEATHER, WITH HIGHS IN THE 60S AND A FEW SPOTS NEAR 70 THURSDAY DUE TO THE LACK OF VEGETATION, AND A FEW SPOTS NEAR 70 THURSDAY DUE TO THE LACK OF VEGETATION, NO LEAVES ON TREES, STRONG SUN DUE TO THE LACK OF VEGETATION, NO LEAVES ON TREES, STRONG SUN ANGLE THIS TIME OF THE YEAR AND NO LEAVES ON TREES, STRONG SUN ANGLE THIS TIME OF THE YEAR AND A SNOWPACK THAT CONTINUES TO ANGLE THIS TIME OF THE YEAR AND A SNOWPACK THAT CONTINUES TO DISAPPEAR. THE WARMTH WILL A SNOWPACK THAT CONTINUES TO DISAPPEAR. THE WARMTH WILL INCREASE OUR CHANCE FOR RAIN DISAPPEAR. THE WARMTH WILL INCREASE OUR CHANCE FOR RAIN SHOWERS THURSDAY NIGHT INTO INCREASE OUR CHANCE FOR RAIN SHOWERS THURSDAY NIGHT INTO FRIDAY BEFORE COOLER AIR SETTLES SHOWERS THURSDAY NIGHT INTO FRIDAY BEFORE COOLER AIR SETTLES BACK IN FOR NEXT WEEKEND AS SEEN FRIDAY BEFORE COOLER AIR SETTLES BACK IN FOR NEXT WEEKEND AS SEEN IN OUR FIRST ALERT 10-DAY&quot;,&quot;video_id&quot;:&quot;1869734467595_578&quot;,&quot;video_length&quot;:&quot;143677&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1869734467595&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="Sunny Skies and Cold Temperatures This Weekend"
	data-vidcid="1:5:2321548"
	data-vidurl="https://www.nbcboston.com/news/local/sunny-skies-and-cold-temperatures-this-weekend/2321548/"
			data-islead="true"
		data-catnames="{&quot;206944&quot;:&quot;News&quot;,&quot;705&quot;:&quot;Local&quot;,&quot;798&quot;:&quot;Weather&quot;,&quot;192546&quot;:&quot;Weather Forecast Video&quot;,&quot;799&quot;:&quot;Weather Stories&quot;}"
	data-tagnames="{&quot;11122&quot;:&quot;temperatures&quot;,&quot;31882&quot;:&quot;weather new england&quot;}"
	data-customdata="{}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBC Universal, Inc.</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="&lt;p&gt;Saturday: Variable clouds, chilly. Light breeze. Highs between 30-35 degrees, wind chill in the teens. Tonight: Mainly clear. Lows near 20 degrees, wind chill 10s. Sunday: Mostly sunny, still cold. Less wind. Highs between 30-35 degrees.&lt;/p&gt;
"
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><span class="icon icon-times"></span></button>
			</figure>
</div>
				<div class="article-content rich-text">
					
					
<p>Winter is holding on tight this weekend with below average temperatures and a light breeze creating wind chills in the single digits and teens. At least there is sunshine to keep us warm and content. </p>

<p>The air mass is very dry so it’s imperative that you use lotion and lip balm to keep your skin hydrated. A wave of energy will drop from Canada and it will enhance upslope snow showers for the mountains of Vermont, New Hampshire and the Berkshires, as well as Litchfield Hills. </p>
<div data-react-component="VideoPlayer" data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_primary_category_id&quot;:192546,&quot;nbc_primary_tag_id&quot;:31882,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_market&quot;:&quot;&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:5:192546&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_WBTS\/244\/919\/7759119322.dfxp&quot;,&quot;mp4_url&quot;:&quot;&quot;,&quot;mpx_download_pid&quot;:&quot;&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;L8SruStfKfTD&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcboston.com\/2021\/03\/WeatherSaturday-1.png?crop&amp;resize=850%2C478&amp;quality=85&amp;strip=all&quot;,&quot;pid_streaming_web_high&quot;:&quot;a5xzGyFgs9sG&quot;,&quot;pid_streaming_web_medium&quot;:&quot;L8SruStfKfTD&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;BOS&quot;,&quot;video_captions&quot;:&quot;&quot;,&quot;video_id&quot;:&quot;1869640259632_306&quot;,&quot;video_length&quot;:&quot;210678&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1869640259632&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}" data-livestream="false" data-title="Wind Chill Leads to Frigid Temperatures Saturday Morning" data-vidcid="1:5:2321401" data-vidurl="https://www.nbcboston.com/weather/video-weather/wind-chill-leads-to-frigid-temperatures-saturday-morning/2321401/" data-islead="false" data-catnames="{&quot;206944&quot;:&quot;News&quot;,&quot;705&quot;:&quot;Local&quot;,&quot;798&quot;:&quot;Weather&quot;,&quot;192546&quot;:&quot;Weather Forecast Video&quot;,&quot;799&quot;:&quot;Weather Stories&quot;}" data-tagnames="{&quot;326257&quot;:&quot;March sun&quot;,&quot;326256&quot;:&quot;negative temperatures&quot;,&quot;46&quot;:&quot;New England&quot;,&quot;326255&quot;:&quot;North country&quot;,&quot;3041&quot;:&quot;snow&quot;,&quot;31882&quot;:&quot;weather new england&quot;}" data-customdata="{&quot;ContentPartner&quot;:&quot;None&quot;,&quot;Source&quot;:&quot;WEBFM&quot;,&quot;SyndicationAllowed&quot;:&quot;true&quot;,&quot;mSNVideoCategories&quot;:&quot;MSN Video v4 Connector-most watched news&quot;,&quot;mSNVideoContentSupplierID&quot;:&quot;NBC_Local&quot;,&quot;mSNVideoCountry&quot;:&quot;us&quot;,&quot;subtitle&quot;:&quot;nosubtitle&quot;,&quot;uploadedByTeam&quot;:&quot;1&quot;,&quot;youtubeChannel&quot;:&quot;None&quot;}" data-autoplay="false" data-cplay="true"></div>
<div class="video_caption" data-react-component="NBCTruncate" data-maxlines="2" data-maxlinesmobile="4" data-readmore="Read more" data-text="Saturday: Variable clouds, chilly. Light breeze. Highs between 30-35 degrees, wind chill in the teens. 
Tonight: Mainly clear. Lows near 20 degrees, wind chill 10s.  
Sunday: Mostly sunny, still cold. Less wind. Highs between 30-35 degrees." data-ellipsis="false">
							Saturday: Variable clouds, chilly. Light breeze. Highs between 30-35 degrees, wind chill in the teens. 
Tonight: Mainly clear. Lows near 20 degrees, wind chill 10s.  
Sunday: Mostly sunny, still cold. Less wind. Highs between 30-35 degrees.
						</div>
<p>Ski areas will pick up between 1-3 inches of fresh snow. A mainly clear sky is expected tonight with low temperatures in the single digits and teens north, while teens and 20s to the south.</p>

<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<em><a href="https://www.nbcboston.com/newsletters/">Get the latest news on COVID-19 delivered to you. Click here to sign up for our coronavirus newsletter.</a></em></blockquote>
</div>
<div class="mobile-app-promotion">
	
<div class="wp-block-nbc-localized-block">
<blockquote class="featured-text">
	<em>Download our mobile app for </em><a href="https://apps.apple.com/us/app/nbc10-boston/id1176170313">iOS<em> </em></a><em>or </em><a href="https://play.google.com/store/apps/details?id=com.nbcuni.nbcots.nbcboston.android&amp;hl=en_US">Android</a><em> to get alerts for local breaking news and weather</em>.</blockquote>
</div>
</div>

<p>High pressure will take control of the region Sunday under a mostly sunny sky and less wind, but it stays chilly with highs in the 30s.</p>

<p>A warm front will allow clouds and temperatures to increase Monday with a slight chance for showers and even snow near the international border. The good news is that this front will open the door to warmer air Tuesday with high temperatures in the 40s in the north and the 50s to the south.</p>

<p>Then, a big warm up is in store midweek. This will be our first prolonged stretch of spring-like weather, with highs in the 60s and a few spots near 70 degrees Thursday. Due to the lack of vegetation, no leaves on trees and a strong sun angle, snowpack will continue to disappear. </p>

<p>The warmth will increase our chance for rain showers Thursday night into Friday before cooler air settles back in for next weekend as seen in our First Alert 10-Day Forecast.&nbsp;</p>
<div class="recirc-module">
	<h3 class="recirc__heading">Weather Stories</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Super-Sized Snowflakes: Vt. Artist Uses Microphotography to Zoom in on Nature" href="https://www.nbcboston.com/news/local/super-sized-snowflakes-vt-artist-uses-microphotography-to-zoom-in-on-nature/2321264/">
							<img class="post__image" src="https://media.nbcboston.com/2021/03/7747599341-1080pnbcstations.jpg?quality=85&#038;strip=all&#038;resize=850%2C478" alt="" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Vermont" class="post__tag" href="https://www.nbcboston.com/tag/vermont/">Vermont</a>
																			<span class="post__date post__date--has-category">
								19 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Super-Sized Snowflakes: Vt. Artist Uses Microphotography to Zoom in on Nature" class="post__title--link" href="https://www.nbcboston.com/news/local/super-sized-snowflakes-vt-artist-uses-microphotography-to-zoom-in-on-nature/2321264/">
								<span data-ellipsis="true" data-text="Super-Sized Snowflakes: Vt. Artist Uses Microphotography to Zoom in on Nature" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									Super-Sized Snowflakes: Vt. Artist Uses Microphotography to Zoom in on Nature								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Cold Wind Continues Before Stretch of Spring-Like Weather" href="https://www.nbcboston.com/weather/stories-weather/cold-wind-continues-before-stretch-of-spring-like-weather/2321150/">
							<img class="post__image" src="https://media.nbcboston.com/2021/03/7747424390-1080pnbcstations.jpg?quality=85&#038;strip=all&#038;resize=850%2C478" alt="" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="Weather" class="post__tag" href="https://www.nbcboston.com/tag/weather/">Weather</a>
																			<span class="post__date post__date--has-category">
								20 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Cold Wind Continues Before Stretch of Spring-Like Weather" class="post__title--link" href="https://www.nbcboston.com/weather/stories-weather/cold-wind-continues-before-stretch-of-spring-like-weather/2321150/">
								<span data-ellipsis="true" data-text="Cold Wind Continues Before Stretch of Spring-Like Weather" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									Cold Wind Continues Before Stretch of Spring-Like Weather								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

									</div>
								<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcboston.com/tag/weather-new-england/">weather new england</a><a class="article-tags__tag" href="https://www.nbcboston.com/tag/temperatures/">temperatures</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F&#038;Low%20Temperatures%20Lead%20Into%20Spring%20Weather%20Ahead?_osource=db_npd_nbc_wbts_fb_shr" data-service="facebook" target="_blank">
			<span class="icon icon-facebook-f"></span>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Low%20Temperatures%20Lead%20Into%20Spring%20Weather%20Ahead&#038;url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F?_osource=db_npd_nbc_wbts_twt_shr" data-service="twitter" target="_blank">
			<span class="icon icon-twitter"></span>
		</a>
	
			<a href="mailto:?body=Low%20Temperatures%20Lead%20Into%20Spring%20Weather%20Ahead%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Flow-temperatures-preface-spring-temperatures-ahead%2F2321529%2F?_osource=db_npd_nbc_wbts_eml_shr" data-service="email" target="_blank">
			<span class="icon icon-envelope"></span>
		</a>
	
			<a href="#" data-service="comments">
			<span class="icon icon-comment-alt"></span>

			<div class="share-buttons__comment-count">
				<div class="fb-comments-count" data-href="https://www.nbcboston.com/weather/stories-weather/low-temperatures-preface-spring-temperatures-ahead/2321529/">0</div>
			</div>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
		};
	</script>
	<div id="mobile-native-below-article" data-react-component="NativeSponsor" data-title="Native Sponsor" data-include-sponsored="true" data-beforetext="Presented By"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
				</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_594" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_594', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Boston, MA"></div>
	<a class="weather-module__conditions" href="https://www.nbcboston.com/weather/">
		<div data-react-component="IframeConditions" data-location="2201"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_562" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_562', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1050270231" class="module-civicScience"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_515" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_515', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_793" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_793', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_923" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_923', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="nbc_newsletter-2" class="widget widget_nbc_newsletter"><div class="newsletter-widget"
				data-react-component="NewsletterWidget"
				data-title="Subscribe to our Newsletters"
				data-description="Sign up to receive breaking news alerts in your inbox."
				data-newsletter-id="WBTS_BreakingNews"
				data-privacy-link="http://www.nbcuniversal.com/privacy/"
				data-newsletter-link=""
				data-nonce="928b59ea73"
				></div></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcboston.com/" class="site-footer__logo">
					<img
						src="https://media.nbcboston.com/2019/09/Boston_On_Light@3x.png?fit=435%2C120&#038;quality=85&#038;strip=all"
						alt="NBC Boston"
						loading="lazy"
					/>
				</a>
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="https://www.facebook.com/NBC10Boston/" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<span class="icon icon-facebook-f"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbc10boston" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<span class="icon icon-twitter"></span>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbc10boston" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<span class="icon icon-instagram"></span>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2024745" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2024745"><a href="/investigations/submit-tip/">Submit a Tip for Investigations</a></li>
<li id="menu-item-2024752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2024752"><a href="/contact-us/">Connect With Us</a></li>
<li id="menu-item-2006777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006777"><a href="https://www.nbcboston.com/newsletters/">Newsletters</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-2006680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006680"><a href="https://publicfiles.fcc.gov/tv-profile/wbts-cd/">WBTS Public Inspection File</a></li>
<li id="menu-item-2220580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2220580"><a href="https://www.nbcboston.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-2006681" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006681"><a href="https://www.necn.com/non-profit-reports/NBC-Non-Profit-News-Partnership-Reports-138336674.html/">NBC Non-Profit News Partnership Reports</a></li>
<li id="menu-item-2006682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006682"><a href="https://www.nbcboston.com/wbts-employment-information/">WBTS Employment Information</a></li>
<li id="menu-item-2006683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006683"><a href="https://www.nbcboston.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2189417" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2189417"><a href="https://www.nbcboston.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-2006685" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006685"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_Boston">Privacy Policy</a></li>
<li id="menu-item-2006687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006687"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_Boston">Do Not Sell My Personal Information</a></li>
<li id="menu-item-2163108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2163108"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Boston">CA Notice</a></li>
<li id="menu-item-2180853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2180853"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2021 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type='text/javascript'>
	(function() {
		function CreateEvent(type, data) {
			var event;

			if ('undefined' === typeof data) {
				data = {};
			}

			try {
				event = new CustomEvent(type, { detail: data });
			} catch (err) {
				event = document.createEvent('CustomEvent');
				event.initCustomEvent(type, true, true, data);
			}

			return event;
		}
	})();
	</script>
			<script type="text/javascript">
		(function() {
						var _sf_async_config      = window._sf_async_config = (window._sf_async_config || {});
			_sf_async_config.domain   = "nbcboston.com";
			_sf_async_config.uid      = 15527;
			_sf_async_config.sections = "stories-weather";
			_sf_async_config.authors  = "Denise Isaac";
			_sf_async_config.title    = "Low Temperatures Lead Into Spring Weather Ahead";
			
			function loadChartbeat() {
				var e = document.createElement('script');
				var n = document.getElementsByTagName('script')[0];
				e.type = 'text/javascript';
				e.async = true;
				e.src = '//static.chartbeat.com/js/chartbeat.js';
				n.parentNode.insertBefore(e, n);
			}
			loadChartbeat();
		})();
		</script>
				<script type="text/javascript">
		window._taboola = window._taboola || [];
		window._newsroom = window._newsroom || [];

		var taboola_config = {};

		taboola_config[decodeURIComponent( 'article' )] = decodeURIComponent( '2321529' );
		taboola_config['tracking'] = '_osource=taboola-recirc';
		_taboola.push(taboola_config);

		!function (e, f, u) {
			e.async = 1;
			e.src = u;
			f.parentNode.insertBefore(e, f);
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		'//cdn.taboola.com/libtrc/nbcots-network/loader.js');

		!function (e, f, u) {
			e.async = 1;
			e.src = u;
			f.parentNode.insertBefore(e, f);
		}(document.createElement('script'),
		document.getElementsByTagName('script')[0],
		"\/\/c2.taboola.com\/nr\/nbcots-wbts\/newsroom.js");
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><span class="icon icon-chevron-left"></span> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcboston.com/weather/stories-weather/low-temperatures-preface-spring-temperatures-ahead/2321529/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><span class="icon icon-times"></span> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcboston.com/">
					<img
						src="https://media.nbcboston.com/2019/09/Boston_On_Light@3x.png?fit=435%2C120&#038;quality=85&#038;strip=all"
						alt="NBC Boston"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcboston.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Meet the Team" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcboston.com/contact-us/">
					Meet the Team				</a>
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcboston.com/weather/">
					Weather				</a>
							<a data-lid="School Closings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="Adjusting to Climate Change" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/weather/stories-weather/climate-change-new-england-adjusting-mitigating/2053436/">
					Adjusting to Climate Change				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="NBC10 Boston Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/investigations/consumer/nbc-boston-responds/">
					NBC10 Boston Responds				</a>
							<a data-lid="Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/videos/">
					Video				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Patriots" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/patriots/">
					Patriots				</a>
							<a data-lid="Red Sox" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/red-sox/">
					Red Sox				</a>
							<a data-lid="Celtics" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/celtics/">
					Celtics				</a>
							<a data-lid="Bruins" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/bruins/">
					Bruins				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Hub Today" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/hub-today/">
					Hub Today				</a>
							<a data-lid="Food &amp; Drink" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/food-drink-nightlife/">
					Food &amp; Drink				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="TV Listings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/live/">
					TV Listings				</a>
							<a data-lid="Find NBC10 Boston" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/news/local/boston-channel-finder/120727/">
					Find NBC10 Boston				</a>
							<a data-lid="Submit a Tip" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/investigations/submit-tip/">
					Submit a Tip				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="https://www.facebook.com/NBC10Boston/" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<span class="icon icon-facebook-f"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbc10boston" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<span class="icon icon-twitter"></span>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbc10boston" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<span class="icon icon-instagram"></span>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<script type='text/javascript' src='https://www.nbcboston.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?m=1611697563g'></script>
<script src='https://www.nbcboston.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.15' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??/wp-includes/js/dist/url.min.js,/wp-includes/js/dist/hooks.min.js?m=1604003340j'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcboston.com/wp-includes/js/dist/api-fetch.min.js?ver=8773a93ea0d1278a2eaa147fdb6eb96d' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??-eJyVzEEOwiAQAMAPWbZUWOFg+hbYQgrC0gSI3zcmfsDzJAPva6HGI/CAcYYaOrCnpQ83UmOgkr7iZyoH5A7Uam0sFOoHERJu2yajtojRCDonv0RNLHK/wX8vN3b1EqTsuqJ0FKyOZPFuPQo/+SjhF+/1KVEqY7TWmD8BxUC6'></script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.6a932ab554a09fb04d91.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/global.3da454403b3883d65fc5.bundle.min.js?ver=1.0.2' id='nbc-global-js-js'></script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/article.e186bb8a0e9da5790ca5.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.94d7df2ffe01b91aaf58.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.2' id='sharethrough-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/186439-278590540860522.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??/wp-includes/js/underscore.min.js,/wp-content/mu-plugins/search/elasticpress/dist/js/facets-script.min.js,/wp-includes/js/wp-embed.min.js?m=1604003340j'></script>
<script src='https://www.civicscience.com/widget/jspoll/?elt=civsci-1050270231&#038;tgtid=51925ac8-1c49-3fe4-2567-331f965147a4&#038;ver=1.0.0' id='nbc-civic-science-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://stats.wp.com/e-202109.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'165596122',post:'2321529',tz:'-5',srv:'www.nbcboston.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596122', '2321529' ]);
</script>

</body>
</html>
