<!doctype html>
<html lang="en-US" class="">
<head>
	<meta charset="UTF-8"><script type="text/javascript">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</script>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	
	<link rel="profile" href="https://gmpg.org/xfn/11">
		<title>Snow Is Returning to New England Tuesday. Here&#8217;s How Much to Expect &#8211; NBC Boston</title>
<link rel='dns-prefetch' href='//ak.sail-horizon.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="NBC Boston &raquo; Feed" href="https://www.nbcboston.com/?rss=y" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.nbcboston.com/_static/??-eJzNks1uwyAQhF+oGNsQhxyqPsv+QIyCwQKsKm9fkipVo1aVml56ndn9ZkEjX1dBKVYbq1zDdvSxSGAR4GxzERFJUvmssFu7pjzJ3+197PhIYWNbrjb7UiWGRCcRPGbIZ1nqOdhu8fFLyrKJW1CxkGmWNkCpntZsb6wLNDe5WhZrKrWId/qVWu6w94dAmX0L+mEEuFkCIX97XJ3t0gbbu1sWVJ+ipOAvDm4+8JVwDAkhdAacm5Tj3moz7CdyCtTDzJgiLGvXq1EhGD2qHgkIjDG7h5mUliXFbiRWdqfY8R4nPozG4tTRvMXTv/oByK0CrTJG4wF03yOyGZj1oDX+qUcOyLYC3VfnZXkepmHUk9n1hzfpXCtR' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<script src='https://www.nbcboston.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script id='jquery-core-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script id='ad-layers-dfp-js-extra'>
var adLayersDFP = {"layerDebugLabel":"Current ad layer","consoleDebugLabel":"Switch to Google console","adUnitPrefix":"div-gpt-ad-"};
</script>
<script id='ad-layers-js-extra'>
var adLayersAdServer = {"jsAPIClass":"AdLayersDFPAPI"};
</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??-eJzTLy/QTc7PK0nNK9EvyClNz8wr1k9M0c1JrEwtKtbNS0rWz0IWSEkr0Msq1tEnSRdQh32uraGZgbmBkbGxuWUWAPH9KX0='></script>
<script src='https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.nbcboston.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script id='nbc-analytics-js-js-extra'>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</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??/wp-includes/js/dist/i18n.min.js,/wp-content/themes/nbc-station/client/build/js/analytics.c116e97290f4b2ccfbbe.bundle.min.js?m=1610655248j'></script>
<link rel="https://api.w.org/" href="https://www.nbcboston.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.nbcboston.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.nbcboston.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.2" />
<link rel="canonical" href="https://www.nbcboston.com/weather/stories-weather/snow-returns-to-new-england-tuesday/2296828/" />
<link rel="alternate" type="application/json+oembed" href="https://www.nbcboston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.nbcboston.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F&#038;format=xml" />
		<style>
		.getty.aligncenter {
			text-align: center;
		}
		.getty.alignleft {
			float: none;
			margin-right: 0;
		}
		.getty.alignleft > div {
			float: left;
			margin-right: 5px;
		}
		.getty.alignright {
			float: none;
			margin-left: 0;
		}
		.getty.alignright > div {
			float: right;
			margin-left: 5px;
		}
		</style>
		<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
	@media (max-width: 375px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcboston.com/2019/09/NBC_Boston-2.png?resize=1440%2C415'); }
	}
	@media (min-width: 376px) and (max-width: 768px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcboston.com/2019/09/NBC_Boston-2.png?resize=1440%2C415'); }
	}
	@media (min-width: 769px) {
		.hero-background:empty { background-image: linear-gradient(to bottom, rgba(0,0,0,0.55) 0%,rgba(0,0,0,0) 20%), url('https://media.nbcboston.com/2019/09/NBC_Boston-2.png?resize=1440%2C415'); }
	}
</style>
<link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Black.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Medium.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/Roboto-Bold.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/Roboto-Regular.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/Roboto-Italic.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/ArthouseOwned-Light.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/fa-brands-400.woff2" as="font" crossorigin /><link rel="preload" href="https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/media/fa-solid-900.woff2" as="font" crossorigin />		<!-- Begin comScore Tag -->
		<script>
		var _comscore = _comscore || [];
		_comscore.push({ c1: "2", c2: "6035083" });
		(function() {
			var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
			s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
			el.parentNode.insertBefore(s, el);
		})();
		</script>
		<noscript>
		<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035083&cv=2.0&cj=1" />
		</noscript>
		<!-- End comScore Tag -->
				<script type="text/javascript">
				window._taboola = window._taboola || [];
						_taboola.push({'article':'2296828', tracking:'_osource=taboola-recirc'});
						!function (e, f, u) {
					e.async = 1;
					e.src = u;
					f.parentNode.insertBefore(e, f);
				}(document.createElement('script'),
				document.getElementsByTagName('script')[0],
				'//cdn.taboola.com/libtrc/nbcots-network/loader.js');
		</script><script>
			window._newsroom = window._newsroom || [];
					!function (e, f, u) {
				e.async = 1;
				e.src = u;
				f.parentNode.insertBefore(e, f);
			}(document.createElement('script'),
			document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/nbcots-wbts/newsroom.js');
		</script>
		<meta property="og:site_name" content="NBC Boston" /><meta name="google-site-verification" content="SCT2EhBzLX0R1J6GJ9IYDwEfS2yDR4CS4hEITRHfekw" /><meta property="fb:app_id" content="168250447207" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@nbc10boston" /><meta name="twitter:creator" content="@nbc10boston" /><meta property="og:type" content="article" /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta name="article:publisher" content="https://www.facebook.com/NBC10Boston/" /><meta name="description" content="Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.  Monday’s break in the action comes courtesy of a slug..." /><meta property="og:description" content="Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.  Monday’s break in the action comes courtesy of a slug of dry air that’s delivered sunshine, reflecting off the freshly fallen 6-12” snow in the Boston Metro for plenty of solar glare…but very little melting with temperatures stuck in the 20s at the…" /><meta name="twitter:description" content="Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.  Monday’s break in the action comes courtesy of a slug of dry air that’s delivered sunshine, reflecting off the freshly fallen 6-12” snow in the Boston Metro for plenty of solar glare…but very little melting with temperatures stuck in the 20s at the…" /><meta property="og:title" content="Snow Is Returning to New England Tuesday. Here&#039;s How Much to Expect" /><meta name="twitter:title" content="Snow Is Returning to New England Tuesday. Here&#039;s How Much to Expect" /><meta name="keywords" content="New England, snow" /><meta property="og:url" content="https://www.nbcboston.com/weather/stories-weather/snow-returns-to-new-england-tuesday/2296828/" /><meta name="twitter:url" content="https://www.nbcboston.com/weather/stories-weather/snow-returns-to-new-england-tuesday/2296828/" /><meta name="sailthru.title" content="Snow Is Returning to New England Tuesday. Here&#039;s How Much to Expect" /><meta name="sailthru.description" content="Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.  Monday’s break in the action comes courtesy of a slug..." /><meta name="sailthru.tags" content="New England, snow" /><meta name="sailthru.tags" content="New England, snow" /><meta name="sailthru.type" content="article" /><meta name="sailthru.date" content="2021-02-08T11:18:33+00:00" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image" content="https://media.nbcboston.com/2019/09/wordpress-1.jpg?resize=1200%2C675" /><meta name="twitter:image" content="https://media.nbcboston.com/2019/09/wordpress-1.jpg?resize=1200%2C675" /><meta name="taboola_lead" content="video" /><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":"https:\/\/www.nbcboston.com\/weather\/stories-weather\/snow-returns-to-new-england-tuesday\/2296828\/","headline":"Snow Is Returning to New England Tuesday. Here's How Much to Expect","datePublished":"2021-02-08T11:18:33","dateModified":"2021-02-08T11:25:30","description":"Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.&nbsp; Monday\u2019s break in the action comes courtesy of a\u2026","speakable":{"@type":"SpeakableSpecification","cssSelector":[".article-headline",".article-subtitle"]},"keywords":"New England, snow","publisher":{"@type":"Organization","name":"NBC10 Boston","logo":{"@type":"ImageObject","height":60,"url":"https:\/\/media.nbcboston.com\/wp-content\/uploads\/2019\/09\/light_amp_wbts.png","width":160}},"image":{"@type":"ImageObject","height":675,"url":"https:\/\/media.nbcboston.com\/2019\/09\/wordpress-1.jpg?resize=1200%2C675","width":1200},"video":{"@type":"VideoObject","contentUrl":"https:\/\/www.nbcboston.com\/weather\/stories-weather\/snow-returns-to-new-england-tuesday\/2296828\/","description":"Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.&nbsp; Monday\u2019s break in the action comes courtesy of a slug of dry air that\u2019s delivered sunshine, reflecting off the freshly fallen 6-12\u201d snow in the Boston Metro for plenty of solar glare\u2026but very little melting with temperatures stuck in the 20s at the&#8230;","duration":"PT03M18S","name":"Snow Is Returning to New England Tuesday. Here's How Much to Expect","thumbnailUrl":"https:\/\/media.nbcboston.com\/2019\/09\/wordpress-1.jpg?resize=1200%2C675","uploadDate":"2021-02-08T11:18:33"},"author":{"@type":"Person","name":"Meteorologist Matt Noyes"}}</script>							<script type='text/javascript'>
				var dfpAdUnits = {};
				var googletag = googletag || {};
				googletag.cmd = googletag.cmd || [];
				(function() {
				var gads = document.createElement('script');
				gads.async = true;
				gads.type = 'text/javascript';
				var useSSL = 'https:' == document.location.protocol;
				gads.src = (useSSL ? 'https:' : 'http:') +
				'//www.googletagservices.com/tag/js/gpt.js';
				var node = document.getElementsByTagName('script')[0];
				node.parentNode.insertBefore(gads, node);
				})();
				</script>
												<script type="text/javascript">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</script>
			<link rel="amphtml" href="https://www.nbcboston.com/weather/stories-weather/snow-returns-to-new-england-tuesday/2296828/?amp"><link rel="icon" href="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://media.nbcboston.com/2019/09/cropped-NBC_Boston-4.png?fit=270%2C270" />
</head>

<body class="post-template-default single single-post postid-2296828 single-format-standard station-nbc wbts has-featured-image short-hero">
	<div id="fb-root"></div>
		<script
			async
			defer
			crossorigin="anonymous"
			src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.3&appId=168250447207&autoLogAppEvents=1"></script>
		<div class="leaderboard_ad">
		<div id="div-gpt-ad-topbanner_" class=" gpt-topbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbanner_', format: 'topbanner', targeting: {"slot":"topbanner","pos":"topbanner"} });
			</script><div id="div-gpt-ad-mobiletopbanner_" class=" gpt-mobiletopbanner" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobiletopbanner_', format: 'mobiletopbanner', targeting: {"slot":"mobiletopbanner","pos":"mobiletopbanner"} });
			</script>	</div>
	<div id="page" class="site" data-component="wrapper">
	
<a class="skip-link screen-reader-text" href="#content">Skip to content</a>
<header id="masthead" class="site-header" role="banner" data-component="siteHeader">
		<div class="site-header__primary">
		<div class="site-header__wrap">
							<div class="site-header__logo">
					<a href="https://www.nbcboston.com/">
						<img
							src="https://media.nbcboston.com/2019/09/Boston_On_Dark@3x-2.png?fit=435%2C120"
							alt="NBC Boston"
							loading="lazy"
						/>
					</a>
				</div>
						<div class="site-header__nav-search">
				<div class="site-header__nav-main">
					<button class="site-header__nav-main-toggle">
						<span class="site-header__nav-main-toggle-text">Main Navigation</span>
					</button>
				</div>
				<div class="site-header__search" data-component="headerSearch">
					<button class="site-header__search-toggle">
						<span class="site-header__search-toggle-text">Search</span>
					</button>
					<div class="site-header__search-form">
						
<form class="search-form" role="search" method="get" action="https://www.nbcboston.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
					</div>
				</div>
			</div>
			<div class="site-header__animated-section">
				<nav class="site-header__nav-sections">
					<div class="menu-primary-container"><nav id="primary-menu" class="menu"><a data-lid="Local" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/local/">Local</a></li>
<a data-lid="Weather" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/weather/">Weather</a></li>
<a data-lid="Investigations" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/investigations/">Investigations</a></li>
<a data-lid="Videos" data-lpos="primary-menu" class=" menu-item menu-item-type-post_type menu-item-object-page" href="https://www.nbcboston.com/videos/">Videos</a></li>
<a data-lid="Sports" data-lpos="primary-menu" class=" menu-item menu-item-type-taxonomy menu-item-object-category" href="/news/sports/">Sports</a></li>
<a data-lid="Traffic" data-lpos="primary-menu" class=" menu-item menu-item-type-custom menu-item-object-custom" href="/traffic/">Traffic</a></li>
</nav></div>				</nav>
				<div class="site-header__weather-tv">
					<div
						class="site-header__local-weather"
						data-react-component="NBCWeather"
						data-view="conditions"
					>
					</div>
										<a class="site-header__live-tv" href="https://www.nbcboston.com/live">Live TV</a>
									</div>
				<button class="site-header__mobile-share-toggle">
					<span class="text-share">Share</span>
					<span class="text-close">Close</span>
				</button>
			</div>
		</div> <!-- site-header__wrap -->
	</div> <!-- site-header__primary -->
	<div class="site-header__secondary">
		<div class="site-header__wrap">
							<div class="site-header__trending">
					<span class="site-header__trending-label">Trending</span>
											<nav class="site-header__trending-nav">
												<a data-lid="10 in Your Town" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/local/ten-towns/" class="site-header__trending-nav-item">10 in Your Town</a>
					<a data-lid="NBA All-Star Voting" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/sports/how-to-cast-your-vote-for-the-2021-nba-all-star-game/2290353/" class="site-header__trending-nav-item">NBA All-Star Voting</a>
					<a data-lid="READ: Updated MA COVID Vaccine Plan" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/local/new-massachusetts-vaccine-timeline-locations-everything-you-need-to-know/2286394/" class="site-header__trending-nav-item">READ: Updated MA COVID Vaccine Plan</a>
					<a data-lid="Tom Brady" data-lpos="trending-stories-module" href="https://www.nbcboston.com/tag/tom-brady/" class="site-header__trending-nav-item">Tom Brady</a>
					<a data-lid="10 Questions" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/local/10-questions-with-nbc10-boston/" class="site-header__trending-nav-item">10 Questions</a>
					<a data-lid="MA COVID Tracker" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/coronavirus/mass-covid-19-tracker-maps-charts-data/2169900/" class="site-header__trending-nav-item">MA COVID Tracker</a>
					<a data-lid="Project Innovation" data-lpos="trending-stories-module" href="https://www.nbcboston.com/news/local/project-innovation-grant-program-features-increased-funding-for-2021/2271024/" class="site-header__trending-nav-item">Project Innovation</a>
		
							</nav>
										<div class="site-header__trending-toggle">
						<button class="trending-toggle"><span class="screen-reader-text">Expand</span></button>
					</div>
				</div>

				
<div class="site-header__alerts">
	<div
		class="site-header__weather with-divider"
		data-react-component="NBCWeather"
		data-view="alerts"
		data-alert-singular="Weather Alert"
		data-alert-plural="Weather Alerts"
		data-zip-code="2201">
	</div>
			<a
			href="https://www.nbcboston.com/weather/school-closings/"
			class="site-header__alerts-item site-header__alerts-item--general"
		>
			19 School Closings		</a>
	</div> <!-- site-header__wrap -->
					</div> <!-- site-header__secondary -->
	</div>
	</header>
	<div id="content" class="site-content " data-component="formsContainer">
		<div id="primary" class="content-area">
			<main id="main" class="site-main">
				<article id="post-2296828" data-component="article">

	<div
			id="template-hero"
		class="template-hero "
		data-component="templateHero"
	>
			<div class="hero-background"></div>
	
	
	
					
	
	
	
	
	
	
	</div>
		<div class="section-content--header below-hero">
		<div class="article-eyebrow__container">
	<div class="article-eyebrow__wrap">
									<a class="article-eyebrow" href="https://www.nbcboston.com/tag/new-england/">New England</a>						</div>
</div>
<div class="article-header--wrap ">
	<h1 class="article-headline">
		Snow Is Returning to New England Tuesday. Here's How Much to Expect	</h1>
			<h2 class="article-subtitle">
			Monday's respite of sunshine is short-lived. Flurries and light snow arrive Tuesday mid-morning, continuing to fall lightly through the day into the early evening before ending. 		</h2>
				
<div class="article-meta" data-component="articleMeta">
	<h4 class="article-byline">
					By <a href="https://www.nbcboston.com?s=Author%3A%20%22Meteorologist%20Matt%20Noyes%22">Meteorologist Matt Noyes</a>							<span class="meta-dot">&bull;</span>
					
							<span class="time-wrap">
				<time class="entry-date published" datetime="2021-02-08T16:18:33-05:00">Published 7 mins ago</time>					<span class="meta-dot">&bull;</span>
				<time class="entry-date updated" datetime="2021-02-08T11:25:30-05:00">Updated 23 seconds ago</time>			</span>
			</h4>
	<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F&#038;Snow%20Is%20Returning%20to%20New%20England%20Tuesday.%20Here%27s%20How%20Much%20to%20Expect?_osource=db_npd_nbc_wbts_fb_shr" data-service="facebook">
			<i class="fab fa-facebook-f"></i>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Snow%20Is%20Returning%20to%20New%20England%20Tuesday.%20Here%27s%20How%20Much%20to%20Expect&#038;url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F?_osource=db_npd_nbc_wbts_twt_shr" data-service="twitter">
			<i class="fab fa-twitter"></i>
		</a>
	
			<a href="mailto:?body=Snow%20Is%20Returning%20to%20New%20England%20Tuesday.%20Here%27s%20How%20Much%20to%20Expect%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F?_osource=db_npd_nbc_wbts_eml_shr" data-service="email">
			<i class="fas fa-envelope"></i>
		</a>
	
	</div>
</div>
	</div>
	</div>
		<div class="section-content--full below-hero">
		<div class="section-content--primary">
			<div class="article-content--wrap">
				<div class="video-flyout" data-component="videoFlyout">
	<figure class="article-featured-media video-lead">
		<div
			data-react-component="VideoPlayer"
		data-meta="{&quot;amp_status&quot;:&quot;&quot;,&quot;spay_email&quot;:&quot;&quot;,&quot;syndicated_id&quot;:&quot;1:11:2401120&quot;,&quot;should_nationalize&quot;:false,&quot;nbc_first_published_date&quot;:&quot;&quot;,&quot;nbc_prevent_modified_update&quot;:false,&quot;nbc_primary_category_id&quot;:14789,&quot;nbc_primary_tag_id&quot;:419,&quot;nbc_social_page_title&quot;:&quot;&quot;,&quot;nbc_page_title&quot;:&quot;&quot;,&quot;nbc_seo_description&quot;:&quot;&quot;,&quot;nbc_social_description&quot;:&quot;&quot;,&quot;nbc_national_headline&quot;:&quot;&quot;,&quot;entities&quot;:&quot;&quot;,&quot;nbc_canonical_url&quot;:&quot;&quot;,&quot;nbc_hide_from_recirculation&quot;:&quot;&quot;,&quot;nbc_hide_from_search&quot;:&quot;&quot;,&quot;nbc_syndication_category&quot;:&quot;1:11:14789&quot;,&quot;nbc_national_collections&quot;:[],&quot;nopreroll&quot;:false,&quot;video_copyright&quot;:&quot;NBC Universal, Inc.&quot;,&quot;sst_source_id&quot;:&quot;&quot;,&quot;nbc_disable_legacy_embeds&quot;:false,&quot;nbc_feed_loader_prevent_updates&quot;:&quot;&quot;,&quot;desktopFlashPid&quot;:&quot;&quot;,&quot;mpx_dfxp_url&quot;:&quot;https:\/\/media.nbcmiami.com\/assets\/video\/NBCU_LM_VMS_-_NECN\/950\/463\/7236492370.dfxp&quot;,&quot;mp4_url&quot;:&quot;http:\/\/nbclim-download.edgesuite.net\/Prod\/NBCU_LM_VMS_-_NECN\/950\/463\/7236492370-1080pnbcstations.mp4&quot;,&quot;mpx_download_pid&quot;:&quot;4NT5hFFmCdW0&quot;,&quot;mpx_high_id&quot;:&quot;&quot;,&quot;mpx_high_url&quot;:&quot;&quot;,&quot;mpx_is_livestream&quot;:&quot;&quot;,&quot;mpx_m3upid&quot;:&quot;&quot;,&quot;mpx_pid&quot;:&quot;3xl97hwG9o4x&quot;,&quot;mpx_thumbnail_url&quot;:&quot;https:\/\/media.nbcboston.com\/2021\/02\/7236492370-1080pnbcstations.jpg?resize=850%2C478&quot;,&quot;pid_streaming_web_high&quot;:&quot;3xl97hwG9o4x&quot;,&quot;pid_streaming_web_medium&quot;:&quot;7AhA1qP4XzbG&quot;,&quot;subtitle&quot;:&quot;&quot;,&quot;dfxp_url&quot;:&quot;&quot;,&quot;video_call_letter&quot;:&quot;NECN&quot;,&quot;video_captions&quot;:&quot;Array&quot;,&quot;video_id&quot;:&quot;1856421443622_189&quot;,&quot;video_length&quot;:&quot;198132&quot;,&quot;video_provider&quot;:&quot;mpx&quot;,&quot;alleypack_schedule_unpublish&quot;:&quot;&quot;,&quot;feed_remote_id&quot;:&quot;mpx_1856421443622&quot;,&quot;feed_thumbnail_url&quot;:&quot;&quot;}"
	data-livestream="false"
	data-title="Forecast: Clearing Monday Before More Snow Tuesday"
	data-vidcid="1:5:2296796"
	data-vidurl="https://www.nbcboston.com/news/local/forecast-clearing-monday-before-more-snow-tuesday/2296796/"
			data-islead="true"
		data-catnames="{&quot;1813&quot;:&quot;On Air&quot;,&quot;1814&quot;:&quot;As Seen On&quot;,&quot;206944&quot;:&quot;News&quot;,&quot;705&quot;:&quot;Local&quot;,&quot;798&quot;:&quot;Weather&quot;,&quot;799&quot;:&quot;Weather Stories&quot;}"
	data-tagnames="{&quot;7849&quot;:&quot;Boston weather&quot;,&quot;224643&quot;:&quot;Boston weather forecast&quot;,&quot;1216&quot;:&quot;forecast&quot;,&quot;46&quot;:&quot;New England&quot;,&quot;23508&quot;:&quot;New England weather&quot;,&quot;256367&quot;:&quot;New England Weather forecast&quot;,&quot;3041&quot;:&quot;snow&quot;,&quot;419&quot;:&quot;Weather&quot;}"
	data-customdata="{}"
			data-autoplay="true"
				data-cplay="true"
	></div>
			<figcaption>
									<cite>NBC Universal, Inc.</cite>
				
															<div
							class="caption"
							data-react-component="NBCTruncate"
							data-maxlines="2"
							data-maxlinesmobile="4"
							data-readmore="Read more"
							data-text="&lt;p&gt;From the NBC10 Boston First Alert Weather Center&#8230;&lt;br /&gt;
Today (Monday):  Fair and chilly. Highs 25-30, wind chill teens.&lt;br /&gt;
Overnight Monday Night:  Light snow late. Lows in the teens.&lt;br /&gt;
Tuesday:  Light snow, 2-3&#8243; east, 3-5&#8243; central/west. Highs near 30.&lt;/p&gt;
"
							data-ellipsis="false">
						</div>
												</figcaption>
						<button class="video-flyout__dismiss"><i class="fas fa-times"></i></button>
			</figure>
</div>
				<div class="article-content rich-text">
					
					
<p>Monday brings a one-day respite from snow, but more accumulating snow is in the forecast for Tuesday.&nbsp; </p>

<p>Monday’s break in the action comes courtesy of a slug of dry air that’s delivered sunshine, reflecting off the freshly fallen 6-12” snow in the Boston Metro for plenty of solar glare…but very little melting with temperatures stuck in the 20s at the warmest time of the day.&nbsp; </p>
<div class="recirc-module">
	<h3 class="recirc__heading">More on Super Bowl Sunday&#039;s Snowstorm</h3>
	<p class="recirc__subheading"></p>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Snowfall Totals: Here&#039;s How Much Snow Fell Across New England on Sunday" href="https://www.nbcboston.com/news/local/snowfall-totals-heres-how-much-snow-fell-across-new-england-2/2296739/">
							<img class="post__image" src="https://media.nbcboston.com/2021/02/snow-ruler.jpg?resize=850%2C478" alt="" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="snowfall totals" class="post__tag" href="https://www.nbcboston.com/tag/snowfall-totals/">snowfall totals</a>
																			<span class="post__date post__date--has-category">
								1 hour ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Snowfall Totals: Here&#039;s How Much Snow Fell Across New England on Sunday" class="post__title--link" href="https://www.nbcboston.com/news/local/snowfall-totals-heres-how-much-snow-fell-across-new-england-2/2296739/">
								<span data-ellipsis="true" data-text="Snowfall Totals: Here&#039;s How Much Snow Fell Across New England on Sunday" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									Snowfall Totals: Here&#039;s How Much Snow Fell Across New England on Sunday								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
					<div class="recirc__post">
			<div class="post__wrap">
				<div class="post__image-wrapper">
											<a data-lpos="inline-recirc-module" data-lid="Cleanup Underway After Sunday Storm Blankets New England With Snow" href="https://www.nbcboston.com/news/local/cleanup-underway-after-sunday-storm-blankets-new-england-with-snow/2296665/">
							<img class="post__image" src="https://media.nbcboston.com/2021/02/norwood_snow.jpg?crop&#038;resize=850%2C478" alt="" loading="lazy" />
						</a>

													<span class="format-icon format-icon--video"></span>
						
															</div>

				<div class="post__text">
					<div class="post__meta">
													<a data-lpos="inline-recirc-module" data-lid="snowstorm" class="post__tag" href="https://www.nbcboston.com/tag/snowstorm/">snowstorm</a>
																			<span class="post__date post__date--has-category">
								3 hours ago							</span>
											</div>

											<h3 class="post__title">
							<a data-lpos="inline-recirc-module" data-lid="Cleanup Underway After Sunday Storm Blankets New England With Snow" class="post__title--link" href="https://www.nbcboston.com/news/local/cleanup-underway-after-sunday-storm-blankets-new-england-with-snow/2296665/">
								<span data-ellipsis="true" data-text="Cleanup Underway After Sunday Storm Blankets New England With Snow" data-react-component="NBCTruncate" data-maxlines="3" data-maxlinesmobile="2" data-readmore="">
									Cleanup Underway After Sunday Storm Blankets New England With Snow								</span>
							</a>
						</h3>
									</div>
			</div>
		</div>
	</div>

<p>Add to the cold air a steady northwest breeze and wind chill values won’t exceed the teens Monday afternoon.&nbsp; </p>

<p>Temperatures will drop the first half of Monday night under a clear sky to start, then clouds will increase with flurries and light snow arriving during the mid-morning, continuing to fall lightly through the day into the early evening before ending.&nbsp; </p>
<p><div style="height: 520px"><script type="text/javascript" src="https://widgets.media.weather.com/wxwidget.loader.js?cid=369362872"></script><wx-widget type="map" zoomlevel="8" menuitems="0099,0017" templateId="0012" mapId="0008" memberId="1470" standalone="true" fullscreen="true" longitude="-71.06" latitude="42.36"></wx-widget></div></p>

<p>With cold air in place for most of New England, the snow will be relatively light in consistency, allowing it to add up fairly easily between three and five inches for most of Southern and Central New England.</p>

<p>There will be a bit less near the South Coast where warmer air provides a mix with and brief change to raindrops during the afternoon…and in Northern New England where less moisture arrives.&nbsp; </p>

<p>Below are the projected snowfall maps:</p>

<figure class="wp-block-image forceratio size-large"><div class="imagewrap1">
				<div class="imagewrap2">
					<img src="https://media.nbcboston.com/2021/02/tuesday-snow-north.png?w=1024" loading="lazy" alt="" class="wp-image-5807366" />
					<span class="placeholder"></span>
				</div>
			</div></figure>

<figure class="wp-block-image forceratio size-large"><div class="imagewrap1">
				<div class="imagewrap2">
					<img src="https://media.nbcboston.com/2021/02/tuesday-snow-south.png?w=1024" loading="lazy" alt="" class="wp-image-5807367" />
					<span class="placeholder"></span>
				</div>
			</div></figure>

<p>Wednesday brings another respite with fair sky and cold winter air, then our First Alert Team will start watching a parade of storms to our south.&nbsp; </p>

<p>With each one that passes by to our south, the question will be how close these come, and whether snow can sneak into southern New England on Thursday (low chance), more of New England Friday (low to moderate chance), then a more likely storm swipe is in the forecast for Sunday and perhaps again the middle of next week.&nbsp; </p>

<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="500" data-dnt="true"><p lang="en" dir="ltr">Storm chances ahead after Tuesday&#39;s snow? Our exclusive in-house <a href="https://twitter.com/NBC10Boston?ref_src=twsrc%5Etfw">@nbc10boston</a> <a href="https://twitter.com/NECN?ref_src=twsrc%5Etfw">@necn</a> Forecast System helps us quantify the chance. We&#39;ll watch a storm to our south Thursday (30%), Friday (40%), Sunday&#39;s is more likely (50%) and next Wednesday (50%). <a href="https://t.co/AVpXOtpvcE">pic.twitter.com/AVpXOtpvcE</a></p>&mdash; Matt Noyes NBC10 Boston &amp; NECN (@MattNBCBoston) <a href="https://twitter.com/MattNBCBoston/status/1358786385885491202?ref_src=twsrc%5Etfw">February 8, 2021</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>

<p>Although it’s unlikely that all of these storms come to fruition, even just some of them is enough for us to encourage New Englanders to push snow back, open up driveways and walkways to allow for pushing more snow back in the days ahead.</p>

									</div>
								<div class="article-footer">
			<div class="article-tags">
	<h4 class="article-tags__heading">This article tagged under:</h4>
	<a class="article-tags__tag" href="https://www.nbcboston.com/tag/new-england/">New England</a><a class="article-tags__tag" href="https://www.nbcboston.com/tag/snow/">snow</a></div>
			<div
	class="share-buttons"
	data-component="sharingBar"
>
			<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F&#038;Snow%20Is%20Returning%20to%20New%20England%20Tuesday.%20Here%27s%20How%20Much%20to%20Expect?_osource=db_npd_nbc_wbts_fb_shr" data-service="facebook">
			<i class="fab fa-facebook-f"></i>
		</a>
	
			<a href="https://twitter.com/intent/tweet?text=Snow%20Is%20Returning%20to%20New%20England%20Tuesday.%20Here%27s%20How%20Much%20to%20Expect&#038;url=https%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F?_osource=db_npd_nbc_wbts_twt_shr" data-service="twitter">
			<i class="fab fa-twitter"></i>
		</a>
	
			<a href="mailto:?body=Snow%20Is%20Returning%20to%20New%20England%20Tuesday.%20Here%27s%20How%20Much%20to%20Expect%0D%0A%0D%0Ahttps%3A%2F%2Fwww.nbcboston.com%2Fweather%2Fstories-weather%2Fsnow-returns-to-new-england-tuesday%2F2296828%2F?_osource=db_npd_nbc_wbts_eml_shr" data-service="email">
			<i class="fas fa-envelope"></i>
		</a>
	
			<a href="#" data-service="comments">
			<i class="fas fa-comment-alt"></i>

			<div class="share-buttons__comment-count">
				<div class="fb-comments-count" data-href="https://www.nbcboston.com/weather/stories-weather/snow-returns-to-new-england-tuesday/2296828/">0</div>
			</div>
		</a>
	</div>
		</div>
					<div id="div-gpt-ad-mobilemultibox_belowarticle" class="widget_ad_layers_ad_widget gpt-mobilemultibox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilemultibox_belowarticle', format: 'mobilemultibox', targeting: {"slot":"mobilemultibox","pos":"mobilemultibox"} });
			</script>	<div id="taboola-below-article-thumbnails"></div>

	<script type="text/javascript">
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbnails-a',
				container: 'taboola-below-article-thumbnails',
				placement: 'Below Article Thumbnails',
				target_type: 'text'
			});
		};
	</script>
	<div id="mobile-native-below-article" data-react-component="NativeSponsor" data-title="Native Sponsor" data-include-sponsored="true" data-beforetext="Presented By"></div>
	<script type="text/javascript">
		var isMobile = window.matchMedia('screen and (max-width: 767px)').matches;
		/** scroll cookie for scroll.com **/
		if (document.cookie.indexOf("scroll0=") < 0 && isMobile) {
			window._taboola = window._taboola || [];
			_taboola.push({
				mode: 'thumbs-feed-03-mobile',
				container: 'mobile-native-below-article',
				placement: 'Below Article Thumbnails - Fallback',
				target_type: 'text'
			});
		};
	</script>
				</div>
		</div>
		<div class="section-content--secondary">
			<aside class="sidebar article-sidebar">
						<section id="ad_layers_ad_widget-2" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-topbox_152" class=" gpt-topbox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'topbox_152', format: 'topbox', targeting: {"slot":"topbox","pos":"topbox"} });
			</script></section><section id="nbc_most_popular-2" class="widget widget_nbc_most_popular"><div class="nbc-most-popular" data-react-component="MostPopular" data-title="Trending Stories" data-include-sponsored="true" data-beforetext="Presented By"></div></section><section id="nbc_weather_widget-3" class="widget widget_nbc_weather_widget">		<div class="nbc-weather-widget">
			<div class="nbc_owned_television_stations_weather_iframe">
	<h3>Weather Forecast</h3><div data-react-component="IframeLocation" data-market-name="Boston, MA"></div>
	<a class="weather-module__conditions" href="https://www.nbcboston.com/weather/">
		<div data-react-component="IframeConditions" data-location="2201"></div>
	</a>
		<div class="widget_sponsor">
		<div id="div-gpt-ad-logo_weather_586" class="sponsored-ad-unit gpt-logo" data-beforetext="Presented By" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'logo_weather_586', format: 'logo', targeting: {"module":"weather","slot":"logo","pos":"logo"} });
			</script>	</div>
</div>
		</div>
		</section><section id="nbc_civic_science-2" class="widget widget_nbc_civic_science"><div id="civsci-1050270231" class="module-civicScience"></div></section><section id="ad_layers_ad_widget-6" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-bottombox_581" class=" gpt-bottombox" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'bottombox_581', format: 'bottombox', targeting: {"slot":"bottombox","pos":"bottombox"} });
			</script></section><section id="ad_layers_ad_widget-12" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-mobilebackstage_814" class=" gpt-mobilebackstage" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'mobilebackstage_814', format: 'mobilebackstage', targeting: {"slot":"mobilebackstage","pos":"mobilebackstage"} });
			</script></section><section id="ad_layers_ad_widget-13" class="widget widget_ad_layers_ad_widget"><div id="div-gpt-ad-interstitial_517" class=" gpt-interstitial" data-beforetext="" data-fallbacktext=""></div><script style="text/javascript">
				if (typeof adInstance === 'undefined') {
					adInstance = new AdLayersAPI();
				}
				adInstance.lazyLoadAd({ slotName: 'interstitial_517', format: 'interstitial', targeting: {"slot":"interstitial","pos":"interstitial"} });
			</script></section><section id="nbc_newsletter-2" class="widget widget_nbc_newsletter"><div class="newsletter-widget"
				data-react-component="NewsletterWidget"
				data-title="Subscribe to our Newsletters"
				data-description="Sign up to receive breaking news alerts in your inbox."
				data-newsletter-id="WBTS_BreakingNews"
				data-privacy-link="http://www.nbcuniversal.com/privacy/"
				data-newsletter-link=""
				data-nonce="aebc8a92b4"
				></div></section>			</aside>
		</div>
	</div>
</article>

			</main>
		</div>

		
	</div><!-- #content -->
	
<footer role="contentinfo" class="site-footer">
	<div class="site-footer__wrapper">
		<div class="site-footer__identity">
							<a href="https://www.nbcboston.com/" class="site-footer__logo">
					<img
						src="https://media.nbcboston.com/2019/09/Boston_On_Light@3x.png?fit=435%2C120"
						alt="NBC Boston"
						loading="lazy"
					/>
				</a>
			
			<ul class="site-footer__social-list">
				
									<li class="site-footer__social-list-item facebook">
						<a href="https://www.facebook.com/NBC10Boston/" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Facebook</span>
							<i class="fab fa-facebook-f"></i>
						</a>
					</li>
				
									<li class="site-footer__social-list-item twitter">
						<a href="https://twitter.com/nbc10boston" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Twitter</span>
							<i class="fab fa-twitter"></i>
						</a>
					</li>
				
									<li class="site-footer__social-list-item instagram">
						<a href="https://instagram.com/nbc10boston" target="_blank" rel="noopener noreferrer">
							<span class="screen-reader-text">Instagram</span>
							<i class="fab fa-instagram"></i>
						</a>
					</li>
							</ul>
		</div>

		<ul id="menu-footer" class="footer-menu site-footer__menu-primary"><li id="menu-item-2024745" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2024745"><a href="/investigations/submit-tip/">Submit a Tip for Investigations</a></li>
<li id="menu-item-2024752" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2024752"><a href="/contact-us/">Connect With Us</a></li>
<li id="menu-item-2006777" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006777"><a href="https://www.nbcboston.com/newsletters/">Newsletters</a></li>
</ul><ul id="menu-secondary-footer" class="footer-menu-secondary site-footer__menu-secondary"><li id="menu-item-2006680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006680"><a href="https://publicfiles.fcc.gov/tv-profile/wbts-cd/">WBTS Public Inspection File</a></li>
<li id="menu-item-2220580" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2220580"><a href="https://www.nbcboston.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-2006681" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006681"><a href="https://www.necn.com/non-profit-reports/NBC-Non-Profit-News-Partnership-Reports-138336674.html/">NBC Non-Profit News Partnership Reports</a></li>
<li id="menu-item-2006682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006682"><a href="https://www.nbcboston.com/wbts-employment-information/">WBTS Employment Information</a></li>
<li id="menu-item-2006683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2006683"><a href="https://www.nbcboston.com/send-feedback/">Send Feedback</a></li>
<li id="menu-item-2189417" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2189417"><a href="https://www.nbcboston.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-2006685" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006685"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/?brandA=Owned_Stations&#038;intake=NBC_Boston">Privacy Policy</a></li>
<li id="menu-item-2006687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2006687"><a target="_blank" rel="noopener noreferrer" href="https://www.nbcuniversal.com/privacy/notrtoo?brandA=Owned_Stations&#038;intake=NBC_Boston">Do Not Sell My Personal Information</a></li>
<li id="menu-item-2163108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2163108"><a href="https://www.nbcuniversal.com/privacy/california-consumer-privacy-act?intake=NBC_Boston">CA Notice</a></li>
<li id="menu-item-2180853" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2180853"><a href="https://info.evidon.com/pub_info/209?v=1&#038;nt=0&#038;nw=false">AdChoices</a></li>
</ul>
				<div class="site-footer__corporate">
			
			<span class="site-footer__corporate-copyright">
				Copyright © 2021 NBCUniversal Media, LLC. All rights reserved			</span>
		</div>
	</div><!-- wrapper -->
</footer><!-- #colophon -->
</div><!-- #page -->

	<script type='text/javascript'>
	(function() {
		function CreateEvent(type, data) {
			var event;

			if ('undefined' === typeof data) {
				data = {};
			}

			try {
				event = new CustomEvent(type, { detail: data });
			} catch (err) {
				event = document.createEvent('CustomEvent');
				event.initCustomEvent(type, true, true, data);
			}

			return event;
		}

		var pdk6Url = "https://www.nbcboston.com/wp-content/themes/nbc-station/static/video/pdk6/player.6.1.3.js";		var pdkScript = pdk6Url;
		if (pdkScript) {
			var s = document.createElement('script');
			s.type = 'text/javascript';
			s.src = pdkScript;
			s.onload = function() {
				window.dispatchEvent(
					CreateEvent('nbc:pdkLoaded')
				);
			};
			document.body.appendChild(s);
		}
	})();
	</script>
	<link rel="stylesheet" href="https://www.nbcboston.com/wp-content/themes/nbc-station/static/video/pdk6/player_smooth.css?v=102319" type="text/css" />		<script type="text/javascript">
		(function() {
						var _sf_async_config      = window._sf_async_config = (window._sf_async_config || {});
			_sf_async_config.domain   = "nbcboston.com";
			_sf_async_config.uid      = 15527;
			_sf_async_config.sections = "stories-weather";
			_sf_async_config.authors  = "Meteorologist Matt Noyes";
			_sf_async_config.title    = "Snow Is Returning to New England Tuesday. Here's How Much to Expect";
			
			function loadChartbeat() {
				var e = document.createElement('script');
				var n = document.getElementsByTagName('script')[0];
				e.type = 'text/javascript';
				e.async = true;
				e.src = '//static.chartbeat.com/js/chartbeat.js';
				n.parentNode.insertBefore(e, n);
			}
			loadChartbeat();
		})();
		</script>
				<div class="facebook-comments">
			<button class="facebook-comments__close"><i class="fas fa-chevron-left"></i> Back to Article</button>
			<div class="fb-comments" data-href="https://www.nbcboston.com/weather/stories-weather/snow-returns-to-new-england-tuesday/2296828/" data-width="100%"></div>
		</div>
		<div class="flyout-nav" data-component="flyoutNav">
	<button class="flyout-nav__close"><i class="fas fa-times"></i> <span class="screen-reader-text">Close Menu</span></button>
	<div class="flyout-nav__logo">
		<a href="https://www.nbcboston.com/">
					<img
						src="https://media.nbcboston.com/2019/09/Boston_On_Light@3x.png?fit=435%2C120"
						alt="NBC Boston"
					/>
		</a>
	</div>
	<div class="flyout-nav__search">
<form class="search-form" role="search" method="get" action="https://www.nbcboston.com/" >
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" value="" name="s" placeholder="Search" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>
</div>
	<div class="flyout-nav__menu">
		<div class="flyout-nav__menu--upper">
							<a data-lid="Coronavirus Pandemic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/coronavirus/">
					Coronavirus Pandemic				</a>
							<a data-lid="NBCLX" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/lx/">
					NBCLX				</a>
							<a data-lid="Local" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/local/">
					Local				</a>
							<a data-lid="Weather" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcboston.com/weather/">
					Weather				</a>
							<a data-lid="School Closings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/school-closings/">
					School Closings				</a>
							<a data-lid="Weather Alerts" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/weather/severe-weather-alerts/">
					Weather Alerts				</a>
							<a data-lid="Request a School Visit" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/news/local/weather-warrior-school-visits/37188/">
					Request a School Visit				</a>
							<a data-lid="Adjusting to Climate Change" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/weather/stories-weather/climate-change-new-england-adjusting-mitigating/2053436/">
					Adjusting to Climate Change				</a>
							<a data-lid="Investigations" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/investigations/">
					Investigations				</a>
							<a data-lid="NBC10 Boston Responds" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/investigations/consumer/nbc-boston-responds/">
					NBC10 Boston Responds				</a>
							<a data-lid="Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/videos/">
					Video				</a>
							<a data-lid="Traffic" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/traffic/">
					Traffic				</a>
							<a data-lid="Virtual Connection" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="https://www.nbcboston.com/news/local/virtual-connection-community-services-for-you-and-your-family-during-the-coronavirus-pandemic/2097887/">
					Virtual Connection				</a>
							<a data-lid="Sports" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/news/sports/">
					Sports				</a>
							<a data-lid="Patriots" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/patriots/">
					Patriots				</a>
							<a data-lid="Red Sox" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/red-sox/">
					Red Sox				</a>
							<a data-lid="Celtics" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/celtics/">
					Celtics				</a>
							<a data-lid="Bruins" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/news/sports/bruins/">
					Bruins				</a>
							<a data-lid="Entertainment" data-lpos="hamburger-menu" class="flyout-nav__menu-item parent-item" href="/entertainment/">
					Entertainment				</a>
							<a data-lid="Hub Today" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/entertainment/hub-today/">
					Hub Today				</a>
					</div>
		<div class="flyout-nav__menu--lower">
							<a data-lid="TV Listings" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/live/">
					TV Listings				</a>
							<a data-lid="Find NBC10 Boston" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/news/local/boston-channel-finder/120727/">
					Find NBC10 Boston				</a>
							<a data-lid="Submit a Tip" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/investigations/submit-tip/">
					Submit a Tip				</a>
							<a data-lid="Submit Photos and Video" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/ugc/">
					Submit Photos and Video				</a>
							<a data-lid="Newsletters" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="https://www.nbcboston.com/newsletters/">
					Newsletters				</a>
							<a data-lid="Our Apps" data-lpos="hamburger-menu" class="flyout-nav__menu-item child-item" href="/products/">
					Our Apps				</a>
					</div>
	</div>
	<div class="flyout-nav__social">
		<h4 class="flyout-nav__social-heading">Follow Us</h4>
		<ul class="flyout-nav__social-list">
			
							<li class="site-footer__social-list-item facebook" rel="noopener noreferrer">
					<a href="https://www.facebook.com/NBC10Boston/" target="_blank">
						<span class="screen-reader-text">Facebook</span>
						<i class="fab fa-facebook-f"></i>
					</a>
				</li>
			
							<li class="site-footer__social-list-item twitter" rel="noopener noreferrer">
					<a href="https://twitter.com/nbc10boston" target="_blank">
						<span class="screen-reader-text">Twitter</span>
						<i class="fab fa-twitter"></i>
					</a>
				</li>
			
							<li class="site-footer__social-list-item instagram" rel="noopener noreferrer">
					<a href="https://instagram.com/nbc10boston" target="_blank">
						<span class="screen-reader-text">Instagram</span>
						<i class="fab fa-instagram"></i>
					</a>
				</li>
					</ul>
	</div>
</div>
<a class="flyout-contact-button" data-lid="Contact Us" data-lpos="hamburger-menu"
			href="/contact-us"
	>
	Contact Us</a>
<script type='text/javascript' src='https://www.nbcboston.com/wp-content/mu-plugins/jetpack-9.4/_inc/build/photon/photon.min.js?m=1611697568g'></script>
<script src='https://www.nbcboston.com/wp-includes/js/dist/vendor/lodash.min.js?ver=4.17.15' id='lodash-js'></script>
<script id='lodash-js-after'>
window.lodash = _.noConflict();
</script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??/wp-includes/js/dist/url.min.js,/wp-includes/js/dist/hooks.min.js?m=1604003343j'></script>
<script id='wp-api-fetch-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script src='https://www.nbcboston.com/wp-includes/js/dist/api-fetch.min.js?ver=8773a93ea0d1278a2eaa147fdb6eb96d' id='wp-api-fetch-js'></script>
<script id='wp-api-fetch-js-after'>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</script>
<script type='text/javascript' src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/common.ad0998aea021a0346c9f.chunk.min.js?m=1612468509g'></script>
<script id='nbc-nonamp-js-js-before'>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</script>
<script src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/nonamp.0a73730210c492357efe.bundle.min.js?ver=1.0.2' id='nbc-nonamp-js-js'></script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/weatherConditions.7c8f498b4e7bd9676e00.bundle.min.js?ver=1.0.2' id='nbc-weather-conditions-js'></script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/global.0fa6b77edd368921a2a0.bundle.min.js?ver=1.0.2' id='nbc-global-js-js'></script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/article.c5de34146f13f64696f0.bundle.min.js?ver=1.0.2' id='nbc-article-js-js'></script>
<script src='https://ak.sail-horizon.com/spm/spm.v1.min.js?ver=1.0.0' id='nbc-sailthru-js'></script>
<script id='nbc-sailthru-js-after'>
if ("undefined" !== typeof Sailthru) { Sailthru.init({"customerId":"757cc89c051f4552fa5708e6f3b93a01"}); }
</script>
<script async src='https://www.nbcboston.com/wp-content/themes/nbc-station/client/build/js/videoPlayer.bb2ce7dffa210f420087.bundle.min.js?ver=1.0.2' id='nbc-video-player-js'></script>
<script src='https://native.sharethrough.com/assets/sfp.js?ver=5.5.2' id='sharethrough-js'></script>
<script defer src='https://js-sec.indexww.com/ht/p/186439-278590540860522.js?ver=1.0.2' id='nbc-index-exchange-js'></script>
<script type='text/javascript' src='https://www.nbcboston.com/_static/??/wp-includes/js/underscore.min.js,/wp-content/mu-plugins/search/elasticpress/dist/js/facets-script.min.js,/wp-includes/js/wp-embed.min.js?m=1604003343j'></script>
<script src='https://www.civicscience.com/widget/jspoll/?elt=civsci-1050270231&#038;tgtid=51925ac8-1c49-3fe4-2567-331f965147a4&#038;ver=1.0.0' id='nbc-civic-science-js'></script>
<script src='https://z.moatads.com/nbcuyieldheader7581548001/moatheader.js?ver=1.0.0' id='moat-js'></script>
<script src='https://stats.wp.com/e-202106.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4',blog:'165596122',post:'2296828',tz:'-5',srv:'www.nbcboston.com'} ]);
	_stq.push([ 'clickTrackerInit', '165596122', '2296828' ]);
</script>

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam-cell.nr-data.net","licenseKey":"53cef82690","applicationID":"189190456","transactionName":"YVBXYBEFVkZSU00NVlgaYEYKS1FbV1VBSkleRQ==","queueTime":0,"applicationTime":1040,"atts":"TRdAFlkfRRkRURteQktI","errorBeacon":"bam-cell.nr-data.net","agent":""}</script></body>
</html>
